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1. Introduction to GXCapture 

GXCapture is specialist modular software for image acquisition, processing and analysis from GXCAM 

cameras (hereinafter referred to as “GXC”). It comprises of two main modules:   

Image Acquisition  

GXCapture can be used with GXCAM cameras and the cameras supplied by GT Vision. It is designed to 

provide a practical interface between the camera and GXCapture, using this software you can achieve , 

with ease, the capture and processing of images and image sequences using live camera controls and 

preview facilities.  The following types of images can be captured   

� Single Image Acquisition  

� Series of images – eg time lapse – time separated 

� Continuous video sequence with compression 

� Single channel capture for subsequent merging (for fluorescence imaging) 

� Low light image capture (long integration periods) 

Image Processing and Labeling   

The images acquired will be displayed on the screen immediately and can then be processed with 

various tools, for example:  

� Contrast, lightness and colour adjustment  

� Resizing and rotation of images 

� Image filters such as sharpening 

� White balance, image merging and greyscaling  

GXCapture can be used to annotate the images with text, shapes and calibrated scalebars 

The other major functional module of GXCapture is image analysis. The values measured (such as the 

length, area and angle) will be shown in a worksheet which can be exported for use in other programs such 

as Excel. There is also a detailed wizard for the calibration procedure to ensure user-friendly operation.  
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2. Basic Operation of GXCapture 2.1.2.1.2.1.2.1. Introduction to GXCapture’s Main Page 

 

                            Diagram 1 GXCapture’s Main Window  

1) Menu bar, this duplicates the functions on the toolbar 

2) Toolbar, this duplicates the functions on the menu bar, the shortcut buttons will open the 

corresponding menu function.    

3) View window, for image editing. 

4) Video camera icon, double-click on the “Video” icon will open the (live preview) window to pop 

up. 

5) Folder bar on left side, this allows you to select a folder.  Any images in this folder will be 

previewed as thumbnails. They can be opened into to GXCapture for processing: 

 



Operation Manual GXCapture                                                          5 

 

GXCapture’s Live Image Interface 

A double-click on the video switch button will trigger GXC’s digital live image capture window, which 

is shown as follows, you can use the shortcut button F11 to expose or hide the toolbar.   

 

Diagram 2 GXCapture’s Digital live Image capture window 2.2.2.2.2.2.2.2. GXCapture’s Image Processing Interface   

In GXC’s main window, click on the button “Open” of the toolbar or “open” in the  dropdown list in 

“File” of the menu bar to import an image from a specified location. Then select the required function from 

the toolbox Standard, Measure, Image and Status Bar from the dropdown list of the button “View” in the 

menu bar.      

 

Diagram 3 GXCapture’s Image Processing Interface 
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 2.3.2.3.2.3.2.3. Reference -  Buttons and Menus  

Toolbar Button Corresponding Menu  Function   

 

File→Open Opens an image file 

 

File→Save As Saves an image with a new filename.  The file 

format can be specified. 

 

Edit→Undo Undo the previous image processing steps 

 

Edit-Redo Redo the previously Undone image processing 

steps 

 

Edit→Move  Moves the displayed position of the image  

 

View→Zoom In Zooms the image 

 

View→Zoom Out Unzooms the image 

 

Help→Help Shows the relevant content of “Help” text.   

 

 

Measure→Line, 

Rectangle, Circle, 

Polygon, etc.  

Selects the required measuring tool to measure 

the image currently being viewed (requires the 

prior selection of the correct calibration for 

accurate dimensional measurements)  

 

Edit→Measure Table  Displays all the measurement data relating to the 

current image.   

 

Edit→Lock Locks the current measurement mode.  

 

Edit→Delete Deletes the currently selected measurement 

annotation  
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3. GXCapture’s Functions  3.1.3.1.3.1.3.1. GXCapture’s Photography Function  

In the main window of GXCapture, users can select the of the camera from which the picture is  to 

be live displayed, captured and imported, the basic settings of the camera at the time of display & capture 

and the live image preview   

3.1.1. Start the Camera  

Double click the “Video” icon in the viewing area.  

  

The live preview window will then pop up.  

If the camera is connected to the computer and an applicable drive is detected, it will start 

displaying the live video automatically.  

 

                   Diagram 4 GXCapture’s Live Preview Image 

If the camera is not connected to the computer or no drive is found al following window will pop 

up.: 

 

Diagram 5 GXCapture’s No Camera Interface  

At this point, please make sure whether the driver has been correctly installed or whether the 

camera is connected to the computer.  
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3.1.2. Camera’s Live Image Display & Capture Settings  

Single Image & Timelapsed Image Sequence Capture 

·Click on  to acquire images.  

Image naming configuration 

·You can set up how each ‘snapped’ image is named by selecting the pulldown list of  , the 

the dropdown window “Config” will pop up, click on the item “Config” to open the dialogue box 

“Config Property of Save” and follow the set up procedures shown below:  

(1) Click on the tab “Snap”, the photography setting window shown below will appear:   

 

Diagram 6 Photography Setting 

(2) Name the image to be saved   

A. , this option decides whether the image to be saved will be 

named with the current time of the system; checking this option will select this file naming 

method; if not, users will be required to manually enter the name of the image to be 

saved in the blank dialogue box on the right of the file name.     

B. Use   to set the extension and format of the image to be saved (such as 

Image1.bmp, Image 1.jpg), options are available in this dropdown list.   (Once 

captured the image can be resaved into a much wider variety of formats in the image 

processing… File …Save As  menu) 

For timelapse simply enter the interval (in seconds) between each capture and the total 

number of images required. 

(3) When the set up is finished, click the button  to save the settings.  
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3.1.3. Video Sequence Capture 

Click following the sequence of “Snap” on the toolbar-> menu “Config” -> dialogue box “Config 

Property of Save”, and then designate the save path through tab “Video”.  

 

Diagram 7 Video Sequence Settings 

      A click on the button “OK” will turn  into , a click on this will then start the video 

sequence record to hard disk function, or stop the videotaping if the video sequence record function is 

already in progress.   

   Re-accessing the setting interface and clicking on the tab “Snap” will switch it back to the 

photography settings interface.  

3.1.4. Settings for Video Sequence Image Recording   ◎ Exposure Time Setting  

Click on the exposure button  on the toolbar of the video playing window or on the settings 

button  (in the tab “Main”) to set the exposure time in M(Minutes), S (Seconds), m (milliseconds).  

The longer the exposure the slower will be the live image refresh and the more light will be gathered by 

the camera before delivering an image to the display. 
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 ◎ Automatic White Balance  

Click on the Auto WB button  in the video playing window to set the white balance. This is 

best done when the camera is pointing at a background image with no specimen.  Make sure the 

image is not over saturated to white with too much light. ◎ Area White Balance  

After the target area is selected, click on the Area WB button  in the video playing window to 

set the white balance.  This is used when you want to select a background area in your image that 

should be white/grey. ◎ Camera Resolution Setting  

       Select the desired video resolution via the dropdown window of the video playing window.   On 

some cameras this will also affect the resolution of the captured image, even if the captured image 

resolution is set higher. 

 

 

                            Diagram 8 Camera Resolution Setting  
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 ◎ Setting of Photographed Images  

When it comes to the settings of photographed images, click on the settings button  first, then 

continue to adjust the settings with the two tabs “Image” and “Parameters” in the dialogue box “Digital 

Camera Setting” .  You can save the parameter settings so that they are automatically loaded when the 

software is used next time, to do this check the tick box at the bottom of the Parameter Tab.  Light 

frequency is used to reduce the beating effect sometimes encountered on microscopes and with room 

illumination, you can select a frequency that does not coincide with the frequency of the illumination, 

adjusting the exposure time can also eliminate this problem. 

  

Diagram 9 GXCapture’s Photographed Images     Diagram 10 GXCapture’s Parameters Settings         

Settings Interface                                        Interface for Photographed Images 
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 3.2.3.2.3.2.3.2. GXCapture’s Image Processing Functions  

This function applies to the processing of acquired images, including cropping, lightness and colour 

adjustment of acquired images.   

3.2.1. GXCapture’s Tools  

GXC’s   tools include “Move” and “Zoom”.  

Toolbar Button  Corresponding Menu Function   

 

Edit→Move To move the image that has been zoomed in.  

 

View→Zoom In (Out)  Zoom in or zoom out the image to be viewed. 

3.2.1.1. Move Tool  

 

If the image is beyond the display area of GXC after zoomed or for its original size, user may use the 

move tool  (in the dropdown menu under button “Edit” of the toolbar or menu bar) to move the 

image in four directions to take a full view of it.   

3.2.1.2. Zoom Tools  【【【【Function 】】】】 

Zooms the image to be viewed.  【【【【Operating Instruction】】】】 

1. Click on the buttons  to select the zoom tool.  

2. Move the mouse on the image and press the mouse left key to zoom the image being viewed.    
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3.2.2. GXCapture’s Image Processing  

This function is for the processing of acquired image, including: adjusting the reversal degree, 

inclination degree and colour of the image.   

3.2.2.1. Reversal of Image  

The reversal of image includes mirror, reversal, left reversal, right reversal, rotation and inclination.  

Button on the Right 

Toolbar 

Corresponding Menu Function   

 

Image Processing→Horizontal 

Mirror  

To mirror the image being viewed  

 Image Processing→Reversal  To horizontally reverse the image for 180 

degrees.  

 

Image Process→Rotation  To rotate the image for a certain angle.  

3.2.2.1.1. Horizontal Mirror  【【【【Function 】】】】 

A click on the button “Mirror” will enable users to mirror the image being viewed.  【【【【Operating Instruction】】】】 

1. The image shown below is the pre-mirroring one.    
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Diagram 4 Pre-Mirroring Image 

2. Click on the button  on the right toolbar, the image will be mirrored, as shown below 

 

Diagram 5 Post-Mirroring Image 

3.2.2.1.2. Reversal  

After reversed, the image titled Diagram 5 will become the one shown below  
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Diagram 6 Post-Reversal Image 

3.2.2.1.3. Rotation  【【【【Function 】】】】 

Click on the button “Rotate”  and set a certain rotation angle through the rotation setting 

window subsequently popping up to rotate the current image.   【【【【Operating Instruction】】】】 

1. A click on the button “Rotate”  will command GXC to pop up the rotation setting window 

shown below  

 

Diagram 20 Image Rotation Angle Setting Window 
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       Rotation angle setting  

       Left rotation for 90 degrees. 

       Right rotation for 90 degrees.    

3.2.2.2. Image Transparency   

This function is designed for image transparency, after which, the image is still ready for removal, split, 

stripping and other operations.   

3.2.2.2.1. Great from lightness 【【【【Function 】】】】 

Defines the image transparency colour range.  【【【【Operating Instruction】】】】 

1. Follow the sequence of “Image→Alpha Channel→ Great from lightness”, then users may 

transparentize the image being shown in the image processing interface.    

2. If you need to adjust the image transparency manually, use   “Image→Alpha Channel→Opacity”, 

then the image transparency may be set through the settings window “Opacity”(as shown below).  

 

Diagram 21 Opacity Setting Window 

·Note:  The opacity setting window also applies to those images that have been treated by the 

function “Great from lightness” for a modification on image transparency for the second time.   
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3. After being processed by the function “create from lightness”, the image will become the one 

shown below 

 

Diagram 22 Image Transparentized by the Function “create from lightness” 

3.2.2.2.2. Remove 【【【【Function 】】】】 

This function is for removing the transparency effect existing in the current image.  【【【【Premise】】】】 

The current image has been transparentized.  【【【【Operating Instruction】】】】 

Use the following the sequence of “Image→Alpha Channel→Remove” to remove the transparency 

effect existing on the current image and restore it to its original state.  

3.2.2.2.3. Split  【【【【Function 】】】】 

To create a new black-and-white image out of the current image which has been transparentized.   【【【【Premise】】】】 

The current image has been transparentized.  【【【【Operating Instruction】】】】 

1. Use the following the sequence of “Image→Alpha Channel→ Great from lightness” to 
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transparentize the current image.  

2. Use the following the sequence of “Image→Alpha Channel→Split”, and then GXC will 

automatically generate a new black-and-white image, which is shown below 

 

Diagram 23  Image Generated by Split 

3.2.2.2.4. Strip  【【【【Function 】】】】 

This function can strip the image that has been transparentized and then generate a new stripped 

image.   【【【【Premise】】】】 

The current image has been transparentized.  【【【【Operating Instruction】】】】 

1. Use the following the sequence of “Image→Alpha Channel→ Great from lightness” to 

transparentize the current image.  

2. Use the following the sequence of “Image→Alpha Channel→Strip”, then GXC will automatically 

generate a new stripped image, which is shown below  
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Diagram 24  Post-Stripping Image 

3.2.2.3. Colour of Image  

This function is used to adjust the colour of images, including grayscale and dither.  

3.2.2.3.1. Grayscale   【【【【Function】】】】 

It applies to giving grayscale treatment to the image being opened.  【【【【Operating Instruction】】】】 

Use the following the sequence of “Image→Gray Scale”, then GXC will automatically initiate the 

grayscale processing, and the result is shown as follows: 

 

Diagram 25 Image Given with Grayscale Treatment 
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3.2.2.3.2. Dither  【【【【Function】】】】 

It’s used to give dither treatment to the image being opened.  【【【【Operating Instruction】】】】 

1. Use the following the sequence of “Image→Dither”, then GXC will automatically cause the dither 

setting window to pop up as shown below 

 

Diagram 26 Dither Effect Setting Window 

2. In the above window, after selecting the desired dither treatment effect, click the button “OK” to 

return to the image processing interface, GXC will then automatically initiate the dither treatment; the 

image shown below is a result of selecting the option “ ”      

 

Diagram 27 Image Given with User-defined Dither Treatment 
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3.2.3. GXCapture’s Filters  

Image adjustments may be realized by applying filters, including the lightening and darkening of 

image, the increase in contrast and the application of Linear filter, Non-linear filter and Deform filter.       

Corresponding Menu Function 

Filters→Repair To set the repair parameters to repair the 

image, used to reduce scratches and noise 

in the image 

Filters→Linear→Sharpen To sharpen the image 

Filters→Linear→Blur To blur the image   

Filters→Linear→Light/Contrast/Gamma To allow users to manually adjust the 

lightness and darkness of the image 

Filters→Linear→Light/Contrast/Gamma To allow users to manually adjust the 

contrast of the image 

3.2.3.1. Threshold  【【【【Function】】】】 

To convert a gray or colour image into a high-contrast black-and-white image.  【【【【Operating Instruction】】】】 

1. Click following the sequence of “Filters→Threshold”, then GXC will cause the threshold setting 

window to pop up as shown below 

 

Diagram 32 Threshold Setting Window 

2. Set the threshold at “118” in the dialogue box of threshold setting window.  

3. “OK”, GXC will automatically starting the conversion of the current image according to the set 

threshold, and the result is shown below.   

 (All the pixels brighter than the threshold “118” are converted into white, while those darker than 

the threshold are converted into black) 



Operation Manual GXCapture                                                          22 

 

 

Diagram 33 Image Converted with the Threshold “118” 

3.2.3.2. Colourize  【【【【Function】】】】 

It’s mainly used to adjust the values in connection with the RGB colour and HSL space and to calculate 

the specific RGB value of an image.   【【【【Operating Instruction】】】】 

1. Use the following the sequence of “Filters→Colourize”, then GXC will cause the colourization setting 

window to pop up as shown below 

 

Diagram 42 Colourization Setting Window 

2. Select HSL or RGB colour mode in the colourization setting window. If HSL mode is chosen, users may 

vary the hue, saturation and blend; if RGB mode is chosen, users may vary the values of red, green 

and blue.  
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3. When the setting is finished, click on the button “OK”, and then GXC will automatically initiate the 

image adjustment.  

3.2.3.3. User-defined Lightening/Contrast/Gamma  【【【【Function】】】】 

Users may define the lightness, darkness, contrast, gamma correction value and other parameters of 

the current image at will.  【【【【Operating Instruction】】】】 

1. Use the following the sequence of “Filters→Light/Contrast/Gamma”, GXC will then cause the 

lightness setting window to appear as shown below 

 

Diagram 34 Lightness Setting Window 

2. Set the lightness value in the lightness setting window (the default lightness value of GXC is “0”, 

which is increased to “50” now for a more obvious lightening effect) 

3. Click on the button “OK” to return to the image processing interface, GXC will then automatically 

start the image lightening, whose result is shown below. 
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Diagram 35 Image with a Lightness of 50 

4. Set the contrast value at “50” in the contrast setting window (GXC’s default contrast value is “0”).  

 

Diagram 36 Contrast Setting Window 

5. Click on the button “OK” to return to the image processing interface, GXC will then automatically 

start the adjustment, with the result as shown below 
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Diagram 37 Image with a Contrast of “50” 

6. Draw the icon  along the bar “Gamma” of the setting window to preview different image 

display effects acquired with different gamma values.    

 

Diagram 41 Gamma Setting Window 

7. When the setting is finished, click on the button “OK”, GXC will then automatically start the image 

adjustment.  

3.2.3.4. Linear  

User may apply tools including “Blur”, “Soften”, “Gaussian Blur”, “Sharpen”, “Edge” and “Emboss” to 

the treatment of image.   

·Blur          It smoothes the image by weakening the colour contrast between neighboring pixels 

with a slight effect, so as to softly soften any obvious edge or prominent shape.   
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·Soften         It softens a smooth edge or an area excessively sharp or of an excessively high 

contrast through producing a blur effect thereon  

·Gaussian Blur  It generates an obliterate thick blur effect on the image by adjusting the colour values 

of pixels and controlling the blur extent according to the curves of Gaussian Algorithm.   

·Sharpen       It sharpens the image through increasing the contrast between neighboring pixels.  

·Edge         It underlines the edges of an image to make the boundary line prominent. 

·Emboss       It generates embossing and indents to various extents by drawing the outline of an 

image and decreasing the colour values of the neighboring area.    

3.2.3.4.1. Blur  【【【【Function】】】】 

It uses blur filter to blur the image.  【【【【Operating Instruction】】】】 

Use the following the sequence of “Filters→Linear→Blur” on the menu bar, then GXC will automatically 

start to blur the current image.  

3.2.3.4.2. Soften  【【【【Function】】】】 

It uses softening filter to soften the image.  【【【【Operating Instruction】】】】 

Use the following the sequence of “Filters→Linear→Soften” on the menu bar, then GXC will 

automatically start to soften the current image.  

3.2.3.4.3. Gaussian Blur  【【【【Function】】】】 

It applies Gaussian blur filter to treat the image with Gaussian blur effect.   【【【【Operating Instruction】】】】 

Use the following the sequence of “Filters→Linear→Gaussian 3*3 (Gaussian 5*5)” on the menu bar, 

then GXC will automatically start to treat the current image with Gaussian blur effect.  

3.2.3.4.4. Sharpen  【【【【Function】】】】 

It applies sharpening filter to sharpen the image.   【【【【Operating Instruction】】】】 

Use the following the sequence of “Filters→Linear→Sharpen” on the menu bar, then GXC will 

automatically start to sharpen the current image.  
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3.2.3.4.5. Edge 【【【【Function】】】】 

It applies edging filter to edge the image.   【【【【Operating Instruction】】】】 

Use the following the sequence of “Filters→Linear→Edge” on the menu bar, then GXC will 

automatically start to edge the current image. 

3.2.3.4.6. Emboss  【【【【Function】】】】 

It uses embossment filter to emboss the image.  【【【【Operating Instruction】】】】 

Use the following the sequence of “Filters→Linear→Emboss”, then GXC will automatically start to 

emboss the current image.  

3.2.3.5. Non-linear  

Users may apply filters including “Noise”, “Medium Value”, “Erode”, “Swell”, “Contour line”, “Edge” 

and “Undulate” to the image. Please refer to “3.2.3.8.Linear” for the application of such non-linear 

filters.  

·Noise         The application of this tool will create some random interfering particles on the image, 

namely the assorted colours. 

·Medium Value  It can adjust and make medium the intensity of each pixel in the image.  

·Erode         It can produce an erosive effect on the image’s colours.  

·Swell         It can swell the image.  

·Contour Line   It can draw fine lines along the edges of different colours in the image and identify 

the contour lines of each colour channel.     

·Edge         It can make prominent the edge of the image to underline the boundary line.   

·Undulate      It can create undulation effect to the image.  

3.2.3.6. Deform filter  

User may apply filters including “Contract”, “Expand Aperture Row”, “Spiral”, “Tubbulate” and 

“Overlap” to deform the image. Please refer to “3.2.3.8.Linear” for the application of the aforesaid 

filters.   

·Contract           It contracts the image around the image’s center to produce a contract effect.  

·Expand Aperture Row It embosses forward the center of the image to expand the aperture row.   

·Spiral              It causes the image to have a distortion effect that peaks at the image’s center 
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and decreases as it reaches the edge to spiral the image.  

·Tubbulate         It deforms the image as it were in a tubbulate item.     

·Overlap          It deforms the image as it were a pile of overlapping images.   

3.2.3.7. Pseudo Colours 【【【【Function】】】】 

It applies the filter “Pseudo Colours” to the image. 【【【【Operating Instruction】】】】 

Use the following the sequence of “Filters→Pseudo Colours”, then GXC will automatically initiate the 

relevant treatment on the current image.   

3.2.3.8. Split  【【【【Function】】】】 

It splits the colour image on the basis of the different colours, hues, saturations, Lums and XYZ spaces. 

The “split of RGB” will be taken as an example here to explain this function.   

·RGB  RGB colour mode is a colour standard prevailing in the industry and represents the channels of 

Red, Green and Blue.  

·HSL  HSL colour mode is a colour standard prevailing in the industry and represents Hue, Saturation 

and Lum.  

·YUV  YUV is a colour coding method adopted by European TV system, these three characters, Y,U 

and V don’t form an English combined word, instead, Y represents Lum, UV represents colour 

difference.  

·YIQ  YIQ colour space generally prevails in the TV system of North America, Y represents the 

grayscale value of the image, I and Q respectively represent the colour and saturation.  

·XYZ  XYZ is a “Split” method that’s based on the region-growing approach of XYZ space.  

·CMYK  CMYK is a colour standard adopted by the printing industry, C,M, Y and K respectively 

represent Cyan, Magenta, Yellow and Black.   【【【【Operating Instruction】】】】 

1. Use the following the sequence of “Filters→Split→Split to RGB”, then GXC will spit the image into Red 

channel, Green Channel and Blue channel according to different RGB colours in the current 

image, the results will be displayed in the image processing interface, users may click on the tabs to 

view the post-split image.    

2. The result of split is shown below 
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Diagram 38 Result of RGB Split 

3.2.3.9. Combining Images  - a powerful function used a great deal in fluorescence microscopy where 

different images have been captured from different filter cubes, these images can now be 

combined. 【【【【Function】】】】 

It combines different images photographed by a black-and-white lens with the R filter, G filter and B 

filter to form colour images.    【【【【Premise】】】】 

Two or more images must be opened in the environment of GXC.  【【【【Operating Instruction】】】】 

1. Use the following the sequence of “Filters→Combine”, then GXC will cause the image combination 

window to pop up as shown below   

 

Diagram 44 Image Combination Window 
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2. Pick the desired colour space for the images to be combined out pf the dropdown list of item 

“Colour” in the image combination window, then choose the channel to be used for combination 

and decide whether to use Alpha channel.  

3. When the setting is finished, click on the button “OK”, then GXC will initiate the image combination.  

3.2.3.10. FFT (Fast Fourier Transformation) 【【【【Function】】】】 

It can apply FFT to the part satisfying certain conditions in the current image.  

·Fourier Transformation  It can represent a function that satisfies certain conditions with a trigonometric 

function (sine and/or cosine function) or the linear combination of their integral.  【【【【Operating Instruction】】】】 

1. Click following the sequence of “Filters→FFT”, then GXC will cause the FFT setting window to pop up 

as shown below.  

 

Diagram 39 FFT Setting Window 

2. Set the transformation parameters in the window above  

· Real:              Select the image to be transformed in the dropdown option list.  

·Imaginar:         Select the image towards which the transformation is oriented in the dropdown 

option list.    

·Inverse:           Checking this option represents the approval to the inversing during the 

transformation.  

·Compute magnitude: Checking this option represents the approval to the calculating of absolute 

value during the transformation.  

·Force FFT:        Checking this option represents the approval to the occurrence of Force FFT during 

the transformation.  

3. When the setting is completed, click on the button “OK”, GXC will then automatically initiate the 

transformation.    

3.2.3.11. Repair  【【【【Function】】】】 
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It repairs the colour image according to the different colours, hues, saturation, lums and XYZ spaces.  【【【【Operating Instruction】】】】 

1. Use the following the sequence of “Filters→Repair”, GXC will cause the repair setting window to pop 

up as shown below.  

 

Diagram 40 Repair Setting Window 

2. Set the colour, radius, iteration of the image after repaired.   

·Colour: Select the colours to be changed to in the dropdown option list, such as RGB or HSL.  

·Radius: Set the radius to be changed to manually.  

·Iteration: Set the iteration to be repaired to manually.  

3. When the setting is completed, click on the button “OK”, GXC will then automatically initiate the 

image repair.  

3.2.3.12. Image Mix  【【【【Function】】】】 

It can mix multiple images into a new one.  

· Note: Different from image combination, image mix doesn’t involve the image’s colour space and 

requires no setting of RGB, HSL and other channels.   【【【【Premise】】】】 

Two or more images must be opened in the environment of GXC. 【【【【Operating Instruction】】】】 

1. Use the following sequence of “Filters→Mix”, GXC will cause the image mix setting window to pop 

up as shown below. 
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Diagram 43 Image Mix Setting Window 

2. Designate the target image and original image in the above setting window, set the mix mode and 

the values of X and Y, then click on the button “Refresh Preview” to preview the post-mix effect of 

the image in the preview area on the left.    

3. When the setting is completed, click on the button “OK”, GXC will then automatically initiate the 

image mix. 

3.2.4. GXCapture’s Measurement Function 

You can measure the currently selected (non-live) and display the results in the “Measurements Table”; 

the measurement covers the distance between points , areas, the angle formed by two intersecting 

lines and point counts.   It is necessary to calibrate the image before measurements are made and 

then vital that the appropriate calibration is selected from the calibration table that corresponds to 

the magnification used when the image was captured (if you have zoomed the image or captured at 

a resolution that is different from the image used to calibrate, the original calibration values cannot be 

used). 
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3.2.4.1. Calibration 【【【【Function】】】】 

Calibration is used to convert the width of one pixel into real units such as microns or millimeters.  This 

value is used in measurements and in the scalebar annotation. 【【【【Operating Instruction】】】】 

1. Capture and store with logical file names (eg: 10XPlanObj_0.5XCMount_1280x1024.jpg) a series 

images of a subject of known length (eg a stage micrometer/graticule) each taken at different 

magnifications. 

2. Go to “Measure→Calibrate”, and the calibration screen will be shown as follows: 

 

Diagram 45 Image Measurement Setting Window 

3. Click on the icon  to load the first of your  images f the stage 

micrometer. 

4. Use the cursor on the image to mark a line between two points a known distance apart (the wider 

apart the better).  For instance 100 microns apart. 

 

Diagram 46 Image Calibration Setting Window 
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Enter the name of the calibration (eg 10XPlan) 

Enter the length of the linein real units (eg 100) 

Select the measurement units (eg um) 

 

Diagram 47 Calibration Settings Window 

5. Click on the button “OK” to exit from the calibration adding window and confirm the calibration results.  

3.2.4.2. Calibration Table  【【【【Function】】】】 

1. Allows you to view, select and change the stored calibrations  

2. allows you to add and delete of calibrations using the “Calibrate Table” 【【【【Operating Instruction】】】】 ◎◎◎◎ View Calibration Result 

1. Use the following sequence of “Measure→Calibrate Table”, GXC will then cause the calibrate table 

window to pop up.  

2., Click on the name of a calibration under the item (such as ) in the left blank of the 

calibrate table, this  will make the corresponding result to appear on the right column as shown 

below 

  

Diagram 7 Operation of Calibration Table 
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 ◎◎◎◎ Changing Calibration Values 

1. Click on the calibration to be changed in the calibration window.  

2. Adjust the data including “Name”, “Length”, “Pixels”, “MeaUnit”  

3. When the editing is finished, click on the button “save” to save the changes.  ◎◎◎◎ Add Calibration Result  

1. Click on the button “add” in the calibration table window, then add a new calibration result titled 

“UnNamed” as shown below 

 

Diagram 8 Additional Calibration Result 

2. Click on the additional calibration result under the item  , then rename it as “L2” 

and change its “Pixels” to “101” in the right column; after save the changes 

 

Diagram 9 Additional Calibration Result after Varied ◎◎◎◎ Delete Calibration Result  

1. Click on the calibration result to be deleted in the calibration table window.  

2. Click on the button “delete”, then the deleting of the designated result is finished. 
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3.2.4.3. Measurement Tool  

    These tools are for measuring of the distance between two points, the angle formed by two intersecting 

lines and the area of a shape drawn in the current image  

Toolbar Button Corresponding Menu Function  

 

Measure→Select To select and move the calibration result displayed 

on the current image and to vary the border 

thickness of such result 

 

Measure→Line To measure the distance between two random 

points in the current image 

 Measure→Rectangle To measure the height and width of the designated 

area as well as the pixels and perimeter of such area 

(measuring unit: pixel)    

 

Measure→Circle  To measure the radius of the designated circular 

area as well as the pixels and perimeter of such area 

(measuring unit: pixel) 

 
Measure→Polygon  To measure the pixels and perimeter of the 

designated polygonal area (measuring unit: pixel) 

 

Measure→Angle To calculate the angle formed by two intersecting 

lines in the current image  

 

Measure→Point To mark points in the image for measurement 

 
Measure→Remark To add remarks in the image  

 

Edit→Backward  To revoke the results of the last 20 measurement 

operations displayed on the current image   

 

Edit→Forward  

 

To restore the results of the last 20 measurement 

operations displayed on the current image   

3.2.4.3.1. Line  【【【【Function】】】】 

It’s used to calculate the distance between two points in the current image, and when the relevant 
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calibration needs to be selected for calibrated measurements to be seen. 【【【【Operating Instruction】】】】 

1. Click on the button  of the toolbar or click following the sequence of “Measure→Line” on the 

menu bar.  

2. Move the mouse onto the image, press the mouse’s left key and drag the mouse to a start position, 

then press the mouse’s left key again to release the measurement tool “Line”.     

3. As shown below, the length of cells indicated in the image is the result measured by the 

measurement tool “Line”.   

 

Diagram 5   Result Measured by “Line” 

3.2.4.3.2. Rectangle 【【【【Function】】】】 

It’s used to measure the height, width, area and perimeter of the drawn  rectangular. 【【【【Operating Instruction】】】】 

1. Click on the button  of the toolbar or click following the sequence of “Measure→Rectangle” on 

the menu bar. 

2. Move the mouse onto the image, press the mouse’s left key and drag the mouse to a proper 

position, then press the mouse’s left key again to release the measurement tool “Rectangle”. 
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· Note:    please refer to the instruction given above for the application of other measurement tools such 

as “Circle”, “Polygon”, “Angle” and “Point”.   

3.2.4.3.3. Select  【【【【Function】】】】 

Selects and moves the calibration result displayed on the current image and allows you to adjust the 

border thickness.  【【【【Operating Instruction】】】】 

1. Click on the button  of the toolbar  

2. Click on a measurement result annotation in the image or onto the border of drawing 

3. When the mouse is on the border” or the measurement result, a press on the mouse left key will 

enable the movement of the measurement result to any position of the image.      

·Note:  when youmove the border, the content of the said measurement result will move with it; but 

the lines will remain still when the content moves.    

4. Double clicking on the border of a drawn line or shape opens the properties  

 

Diagram 54    Properties of the Result Measured by “Rectangle” 

5. In the properties window you may change the text font and drawing appearance of the current 

selected drawing 

6. Click on the button “OK” to return to the image processing interface  

·Note:   the border thickness of all measurement tools shall fall between “1”and “4”without hitting the 

both ends.  
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Diagram 56 “Rectangle” measurement after being changed in Properties 

3.2.4.3.4. Remark (Text annotation) 【【【【Function】】】】 

It’s used to add marks and remarks to the image for viewing image information.    【【【【Operating Instruction】】】】 

1. Click on the button  of the toolbar or click “Measure→Remark” on the menu bar. 

2. Move the mouse onto the position where the remarks is needed in the image, press the mouse’s left 

key, this opens the editing window: 

 

Diagram 57 Remarks Editing Window 

3. In the window above, users can edit the text of the remark, change the typeface through 
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, change the colour through  and make the background of the 

remarks transparent or not  .   

 

Diagram 58 Post-editing Remarks 

    4. Click on the button “OK” to add the post-editing remarks to the image; The follow image 

demonstrates the status where a remarks is successfully added to the image. 

 

Diagram 59 Remarks’ Effect Setting Window 



Operation Manual GXCapture                                                          41 

 

3.2.4.4. Measure Table 【【【【Function】】】】 

It’s for viewing the information in connection with measurement and remarks already existing in the 

current image.    【【【【Operating Instruction】】】】 

1. Click following the sequence of “Measure→Measure Table” on the menu bar, then GXC will cause 

the measurement data window to pop up as shown below 

 

Diagram 11 Measurement Data Window 

2. The content of measurement and the information of remarks already existing in the current image 

will be displayed in the window above.   

3. If there’s a need to save the measurement data, click on the button  in the lower 

left corner, GXC will then automatically save the content of the “Measure Table” into the file titled 

“MeasureInfo.txt” under GXC.    


